Az ERR_SSL_OBSOLETE_VERSION figyelmeztetés kijavítása a Chrome-ban

Written by redzs

2022.08.28.

Kategóriák

Az ERR_SSL_OBSOLETE_VERSION figyelmeztetés kijavítása a Chrome-ban

Az ERR_SSL_OBSOLETE_VERSION figyelmeztetés kijavítása a Chrome-ban

Az egyik leginkább aggasztó hiba, amellyel a webhely látogatói találkozhatnak, a biztonsági figyelmeztetés. A brute force támadások, a rosszindulatú programok és a szolgáltatásmegtagadási támadások mellett rendkívül fontos, hogy az internethasználók biztonságosan böngészhessenek és vásároljanak. Ha webhelye az ERR_SSL_OBSOLETE_VERSION figyelmeztetést jeleníti meg, a látogatók nem érhetik el webhelyét anélkül, hogy rákattintanának a hibaüzenetben szereplő hivatkozásra, amely lényegében azt jelzi, hogy ne térjenek vissza.

ERR_SSL_OBSOLETE_VERSION Figyelmeztetés

Ebben a bejegyzésben megvitatjuk, hogy mi az ERR_SSL_OBSOLETE_VERSION figyelmeztetés, és milyen lépéseket tehet a javítás érdekében. Azt is megmutatjuk, hogyan tesztelheti helyileg ezeket a javításokat a két leggyakoribb webszerveren – az Apache-on és az NGINX-en. Rock and roll.

Mi az ERR_SSL_OBSOLETE_VERSION figyelmeztetés?

Az ERR_SSL_OBSOLETE_VERSION figyelmeztetés egy hibaüzenet, amelyet a webhely látogatói látnak, ha a biztonsági tanúsítvány elavult verzióját, például TLS 1.0 vagy 1.1 verziót használ. A Chrome 72 kiadásától kezdődően ezek a verziók már nem támogatottak.

Mi a TLS vs SSL?

A Transport Layer Security (TLS) egy internetes biztonsági protokoll, amely lehetővé teszi a hitelesítést és a tartalom biztonságos szállítását az interneten. Biztonságossá teszi például a hitelkártya használatát vásárlásokhoz vagy az alkalmazotti kérelmek bizalmas információkkal való kitöltését a webhelyeken.

A Secure Socket Layers (SSL) egy elavult módszer a kliens és a kiszolgáló közötti kapcsolat titkosítására, amelyet az új TLS-módszer váltott fel. A TLS és az SSL közötti különbség manapság valójában csak terminológia kérdése. A legtöbben még mindig az SSL kifejezést használják, bár a TLS a ténylegesen használt protokoll.

Miért érdekelne a TLS, ha rendelkezik SSL-szel?

Ahogy korábban említettük, webhelye technikailag már amúgy sem használ SSL -t. Általánosságban elmondható, hogy manapság minden SSL-tanúsítvány valójában TLS-tanúsítvány. A legtöbb tárhelyszolgáltató továbbra is az SSL-tanúsítvány kifejezést használja az általa hozott ismertség miatt, de a TLS-t biztonsági és sebességbeli előnyei miatt használja.

Hogyan javíthatja ki az ERR_SSL_OBSOLETE_VERSION problémát a szerver TLS-verziójának frissítése

2019-ben a Google bejelentette, hogy leállítja a TLS 1.0-t és 1.1-et a Chrome-on a biztonsági rések miatt. A TLS 1.3 2018-as kiadása óta a Chrome-nak legalább 1.2-es verziója szükséges a webhelyek figyelmeztetés nélküli megjelenítéséhez. Ennek eredményeként a TLS korábbi verzióit használó webhelyek egy csúnya ERR_SSL_OBSOLETE_VERSION üzenetet kapnak. A TLS nem támogatott verzióinak használata veszélyes – nemcsak a webhelyére, hanem a látogatóira is.

A legtöbb nagyobb böngésző már támogatja a TLS 1.3 -at (az IE kivételével) , és 2020 óta ez az alapértelmezett szállítási biztonság a Google , a Youtube és a Netflix számára. A TLS 1.3 nemcsak magasabb szintű biztonságot kínál, hanem sokkal gyorsabban továbbítja az adatokat. Például a TLS 1.3-nak feleannyi időbe telik az adatok átvitele a látogató böngészőjéből a szerverre, mint a TLS 1.2-nél. Ezenkívül más internetes protokollok, például a HTTPS, SMTP és (e-mailekhez használt POP3) már a TLS újabb verzióit használják. Még akkor is, ha nem kap figyelmeztetést webhelyén, győződjön meg arról, hogy webhelyén legalább a TLS 1.2-es verziója fut. A webhely biztonsága attól függ.

Az ERR_SSL_OBSOLETE_VERSION javítása a Chrome-ban

Ha már látja ezt a hibát a Chrome-ban, amikor megpróbál hozzáférni webhelyéhez, akkor több mint valószínű, hogy webhelye elavult TLS-verziót futtat. A probléma megoldásához különféle módszerekre lesz szükség, amelyek végső soron az adott tárhelyszolgáltatótól függenek. Kezdésnek azonban remek kiindulópontja annak ellenőrzése, hogy a TLS melyik verziója fut a webhelyén.

Hogyan találhatja meg, hogy a webhelye melyik TLS-verziót futtatja

Ezeket az információkat a Chrome-ban a fejlesztői eszközök és egy billentyűparancs segítségével érheti el. Nyomja meg a Command+Option+C billentyűket (Mac rendszeren) vagy a Control+Shift+C (Windows és Linux rendszeren). Ezután kattintson a Biztonság fülre. A képernyő felugrik, és megmutatja a webhelyén futó TLS-verziót.

ERR_SSL_OBSOLETE_VERSION ellenőrző

Hogyan lehet megtudni, hogy a webhelygazda/szerver melyik TLS-verziót futtatja

Mielőtt kapcsolatba lépne a gazdagéppel, vagy bármilyen módosítást végezne a webtárhely fájljain, érdemes ellenőrizni, hogy a gazdagép szervere támogatja-e a TLS 1.2-es vagy 1.3-as verzióját. Ezt úgy érheti el, hogy felkeresi a Geekflare TLS-ellenőrzőjét . Írja be a gazdagép URL-jét, és kattintson a küldés gombra. Amikor megjelennek az eredmények, görgessen lefelé, amíg meg nem jelenik a telepített protokollok. Keresse a TLS 1.2-es és 1.3-as verzióit. Ha támogatottak, akkor mindegyik mellett az igen felirat látható.

TLS teszt

Vegye fel a kapcsolatot vagy frissítse tárhelyszolgáltatóját

Miután meggyőződött arról, hogy webhelye és/vagy szervere elavult TLS-verziót futtat, a legegyszerűbb megoldás az ERR_SSL_OBSOLETE_VERSION hibára az, ha felveszi a kapcsolatot a tárhelyszolgáltatójával, hogy megállapítsa, frissíthető-e a TLS-verziója. Ha TLS 1.0-ról vagy 1.1-ről TLS 1.2+-ra vált, az megoldja a problémát. Ha ez nem lehetséges, itt az ideje, hogy új tárhelyet keressen a webhelyéhez.

Teszteket végeztünk több vezető tárhelyszolgáltatón, hogy teszteljük szerverük TLS 1.3 futtatására való képességét. A Siteground , a WP Engine, a Pressable , a Flywheel , a Bluehost és a Cloudways mind támogatják. Tehát, ha ezen szolgáltatók bármelyikével üzemelteti a rendszert, valószínűleg nem fogja látni az ERR_SSL_OBSOLETE_VERSION hibát. Azonban meg kell jegyeznünk, hogy csak azért, mert egy tárhelyszolgáltató támogatja a legújabb TLS-verziót, ez nem jelenti azt, hogy ténylegesen futtatja azt. Néhány webtárhely alapértelmezés szerint továbbra is 1.1-et használ, ami nem jó. Ezért fontos ellenőrizni, hogy melyik verzió van jelenleg telepítve webhelyére.

Az ERR_SSL_OBSOLETE_VERSION hiba javításának tesztelése helyi kiszolgálón

Ha meg szeretné győződni arról, hogy a TLS-verzió frissítése kijavítja a webhely ERR_SSL_OBSOLETE_VERSION hibáját, bármikor tesztelheti egy helyi szerver segítségével.

Ha WordPresst használ, akkor a tárhelyszolgáltató valószínűleg Apache vagy NGINX webszervert használ. Ebben az oktatóanyagban egy helyi szerver és MAMP Pro segítségével szerkesztjük az SSLProtocol fájljainkat Apache és NGINX rendszeren a TLS 1.0 és 1.1 letiltásához. Ezután engedélyezzük a TLS 1.2 és 1.3 támogatását. Ha Windows-os gépet használ, követheti velünk a WAMP -ot, hogy elvégezze ugyanazt a feladatot.

Az ERR_SSL_OBSOLETE_VERSION MAMP Pro figyelmeztetés javítása

Szeretnénk megismételni, hogy egyeztessen házigazdájával, hogy támogatja-e a TLS 1.2-es vagy 1.3-as verzióját. Az SSL-protokollok megfelelő támogatás nélküli módosítása az SSL-tanúsítvány feltörését eredményezi.

A TSL-verzió frissítése az Apache-ban a Mamp Pro segítségével

Ha a MAMP Pro-t használja ehhez az oktatóanyaghoz, akkor feltételezzük, hogy már ismeri a WordPress webhely létrehozását és az SSL telepítését. Ha útmutatásra van szüksége, hogyan teheti ezt meg, tekintse meg Ultimate Guide to MAMP Pro for WordPress felhasználók számára című cikkünket .

A TLS 1.0 és 1.1 letiltása az Apache-ban

A TLS 1.0 és 1.1 letiltásához az Apache-ban, szerkesztenie kell a webszerver SSL-protokollját tartalmazó konfigurációs fájlt. A használt platformtól függően ez a fájl különböző helyeken található.

Egy alapértelmezett Apache helyen valószínűleg itt található:
/usr/local/apache2/conf/extra/httpd-ssl.conf

Ha Ubuntu/Debian szervert futtat, a fájl valószínűleg itt található:
/etc/apache2/mods-enabled/ssl.conf

Végül, ha helyi szervert futtat macOS rendszeren a MAMP Pro segítségével (ahogyan mi is), a fájl itt található:
/mamp/conf/apache/extra/httpd-ssl.conf

Ezután keresse meg az SSL-protokoll támogatás szakaszt , amely néhány sor kódból áll. Ez a httpd-ssl.conf fájl alapértelmezett beállítása:

SSLProtocol alapértelmezett fájl

Az engedélyezett protokollok meghatározásához nézze meg a kód utolsó két sorát.

A TLS 1.0 és 1.1 engedélyezve van

Meg kell mondanunk az Apache-nak, hogy csak a TLS 1.2 vagy újabb verzióit futtassa. Jelenleg minden verzió engedélyezve van. Ennek megváltoztatásához módosítsa az SSLProtocol all -SSLv3 SSLProxyProtocol all -SSLv3 paramétert a következőre:

01
SSLProtocol TLSv1.1 TLSv1.2

A fájlnak most így kell kinéznie:

Nincs ERR_SSL_OBSOLETE_VERSION Apache

Az utolsó lépés a szerver újraindítása. Miután a szerver újraindul, nyissa meg webhelyét egy inkognitóablakban. Az ERR_SSL_OBSOLETE_VERSION figyelmeztetésnek eltűnnie kell. Nyissa meg webhelyét, és használja a fejlesztői eszközöket a biztonsági beállítások megtekintéséhez.

TLS 1.2 teszthely

A TLS-verzió frissítése NGINX-ben a Mamp Pro segítségével

Az SSLProtocol frissítéséhez egy NGINX webszerveren meg kell találnia a webhely konfigurációs fájljait. Az elsődleges NGINX konfigurációs fájlban is megtalálható, mint a MAMP Pro esetében. A fájl MAMP használatával történő szerkesztéséhez lépjen a mamp/conf/nginx/nginx.conf oldalra . Nyissa meg a fájlt a HTML/szövegszerkesztővel. Ehhez az oktatóanyaghoz a BBedit-et használjuk, de bármelyik szerkesztő megteszi. Ha nem követi a MAMP Pro használatát, az nginx.conf fájl általában az /etc/nginx/nginx.conf fájlban található .

Görgessen lefelé, amíg meg nem látja az ssl_protocols karakterlánccal kezdődő sort . Ha az összes TLS-verzió engedélyezve van, a fájl így fog kinézni:

Alapértelmezett NGINX fájl

Amint láthatja, a TLS 1.0, 1.1 és 1.2 engedélyezve van, de az 1.3 nem támogatja. Ennek megváltoztatásához módosítsa az ssl_protocols TLSv1 TLSv1.1 TLSv1.2 értéket; a következőkre:

NGINX szerkessze ezt a sort

01
ssl_protocols TLSv1.2 TLSv1.3;

A fájlnak most így kell kinéznie:

Javított NGINX fájl

A szerver most csak az 1.2-es és 1.3-as TLS-verziót használja. A megerősítéshez indítsa újra a szervert, és húzza fel webhelyét a Chrome-ban. Ellenőrizze a beállításokat a fejlesztői ellenőrző eszközök segítségével. Mint korábban említettük, ezt úgy teheti meg, hogy megnyomja a Command+Option+C billentyűket (Mac rendszeren) vagy a Control+Shift+C (Windows és Linux rendszeren), majd kattintson a Biztonság fülre.

Szeretnénk megemlíteni, hogy az alapértelmezett konfiguráció beállításait felülírhatja egy adott tartomány szerverblokkja. Ha végrehajtotta a javításunkat, és továbbra is az ERR_SSL_OBSOLETE_VERSION figyelmeztetést kapja, akkor ez lehet a kiváltó ok.

A dolgok lezárása

Mivel a biztonsági aggályok rohamos ütemben nőnek, fontos, hogy webhelyét naprakészen tartsa a TLS legújabb verzióival. Tudjuk, hogy a böngészőhibák frusztráló élményt jelenthetnek, különösen akkor, ha nem tudja, mit tegyen a javításukhoz. A problémát olyan eszközökkel ellenőrizheti, mint a Chrome Dev Tools és a Geekflare TLS-ellenőrzője. De sajnos a probléma megoldása a TLS-verzió frissítése, amely csak szerver szinten lehetséges. Tehát a legjobb, ha felveszi a kapcsolatot a szolgáltatóval, vagy ha szükséges, frissíti a tárhelyszolgáltatóját, hogy megbizonyosodjon arról, hogy támogatja az új TLS-verziókat. Hasznos lehet a TLS újabb verzióinak tesztelése a webhelyén, helyileg Apache és NGINX webszervereken. Ez segít abban, hogy a látogatók ne szembesüljenek a csúnya ERR_SSL_OBSOLETE_VERSION figyelmeztetéssel, amikor életbe lépteti a változtatásokat.

Találkozott már valaha az ERR_SSL_OBSOLETE_VERSION figyelmeztető hibával a Chrome-ban? Ha igen, hallgassa meg az alábbi megjegyzés részben.

0 hozzászólás

Egy hozzászólás elküldése

Az e-mail címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük

n/a
Egyéb kategóriaAz ERR_SSL_OBSOLETE_VERSION figyelmeztetés kijavítása a Chrome-ban